• Ask a Question
150
Insert Image Size must be less than < 5MB.
    Ask a Question
    Cancel
    150
    More answer You can create 5 answer(s).
      Ask a Poll
      Cancel

      Delay after keyboard command

      Please help.  I’ve been looking for a solution to this for 6 months already.

      The problem started when I upgraded to Windows 10.  I was running Autocad 2016 at the time, have since upgraded to 2017 and also installed all service packs for Windows and Autocad, to no avail.

       

      I bought a brand new Microsoft windows 10-compatible mouse, not the solution either.

      Problem:

      When I enter a command using the keyboard, there is a 1-2 second delay before I can select or click in the model space.  Eg. if I hit ‘L’ for line and I click in model space immediately, the click is ‘dead’.  If I wait a second or two before clicking, this does not happen.  BUT, if I use the toolbar button for line, I can click in model space and start drawing immediately.  A second doesn’t sound like much, but it is slowing me down considerably and frustrating me incredibly.

      The same applies to any other keyboard command.   When I enter the command using the keyboard, I have to wait 1-2 seconds before I can select objects or start drawing.  The mouse is moving during these 1-2 seconds, it’s not like it freezes.  But the clicking has no effect.

      I have searched everywhere for a solution and tweaked every setting I could find.

      Does anyone have an ideas for how to fix this?

       

      25 Answers

      msi.

      Answered by KMWilson on March 24, 2017..

      does it happen on every key stroke? or every command?

      looks like your issue is nothing to do with AutoCAD. It’s your laptop/keyboard.

      On wireless keyboards there may be some initial delay after a while of idle. Reason for this is saving the battery from mistakenly pressed key. Your issue sounds similar to this.

       

      When you type anything in Excel/Word, does it happen on every key stroke?

      Or does it happen only if you leave the keyboard for a while and then press a key?

       

      edit: do you have any other device connected to your laptop? or is your laptop connected to any other device via bluetooth? If so, try switching off the bluetooth/wireless, see if it makes any difference.

      edit 2: if you have “MSI Gaming App” installed, close it and try again (just read something similar to your issue on web, and it worked on that example)

       

      Answered by SBCansever on March 24, 2017..

      Hi SBCansever

      On CAD, it happens after any command I enter using the keyboard.  If I use the shortcut buttons on the ribbons I don’t get the same issue.  But I have been using mostly keyboard shortcuts for 15yrs, I draw faster that way.  The delay is in the computer responding to the mouse clicks after I’ve used the keyboard.

      On word/excel, it happens for instance when I type in one line/cell, and then click my mouse to reposition the cursor in another line/cell.  I have to click two or three times before the computer responds to the mouse clicks.  In this time, the mouse is not frozen, I can move, but the clicking has no effect.

      The keyboard is not wireless.

      There are no other devices connected to the laptop, no bluetooth either.

      No MSI gaming app.  I am not into gaming 🙂

      Regds

      Karin

       

       

      Answered by KMWilson on March 25, 2017..

      Hey there KMWilson,

       

      What’s the make and model of your laptop?

      Answered by JavaParaTrooper on March 29, 2017..

      It’s an MSI laptop.

      I tried a few more things last night.  and after restarting the problem is finally fixed… after 6 months of struggling with it.  🙂

      I think this is what did the trick:

       

      Go to: Settings->Devices->Mouse and touchpad->Additional Mouse Options

      Go to the TouchPad tab

      Click on Additional tab

      Palm tracking – slide all the way to minimum

       

       

      Super simple fix but totally bizarre because I am not even using the touchpad, it is disabled and I am using a usb mouse.

       

      Anyway my problem is solved.

       

       

      Answered by KMWilson on March 29, 2017..
      • I am very glad that you were able to solve the problem, I have been busy searching myself for the past 4 days, it seemed like a most strange problem.   Hope all is well 🙂

        on March 30, 2017.
      • Wooooooohooooooooo!!!! I’ve been following this thread with interest. Great to see it finally has been fixed.

        6 months of agony resolved. Great to see so many people pitch in with ideas too!

        on March 30, 2017.
      Cancel
      Add comment