Delay after keyboard command

Please help.  I’ve been looking for a solution to this for 6 months already.

The problem started when I upgraded to Windows 10.  I was running Autocad 2016 at the time, have since upgraded to 2017 and also installed all service packs for Windows and Autocad, to no avail.

 

I bought a brand new Microsoft windows 10-compatible mouse, not the solution either.

Problem:

When I enter a command using the keyboard, there is a 1-2 second delay before I can select or click in the model space.  Eg. if I hit ‘L’ for line and I click in model space immediately, the click is ‘dead’.  If I wait a second or two before clicking, this does not happen.  BUT, if I use the toolbar button for line, I can click in model space and start drawing immediately.  A second doesn’t sound like much, but it is slowing me down considerably and frustrating me incredibly.

The same applies to any other keyboard command.   When I enter the command using the keyboard, I have to wait 1-2 seconds before I can select objects or start drawing.  The mouse is moving during these 1-2 seconds, it’s not like it freezes.  But the clicking has no effect.

I have searched everywhere for a solution and tweaked every setting I could find.

Does anyone have an ideas for how to fix this?

 

Asked on March 21, 2017 in AutoCAD.
Add Comment
25 Answer(s)

Hi Bill

I’ve played around with the autocomplete settings and turned it off completely, makes no difference.

 

SBCansever, typing the full command also doesn’t make a difference.

 

I have realised that I have a similar issue in microsoft excel when switching from keyboard input to mouse input, so maybe this is not a cad issue after all.

 

Answered on March 22, 2017.
Add Comment

Then its worth to double check your keyboard setting in Windows; sticky keys, repeating time etc..

Answered on March 22, 2017.
Add Comment

Hi Mostafa & SBCansever

Filter keys is turned off, and so is sticky keys.

I turned on the on-screen keyboard and tried typing on that keyboard.. and then the problem does not occur.   But obviously I can’t work like that all the time. So it seems the problem lies somewhere with the laptop’s keyboard..

but I have already tried plugging in another external keyboard, and that also didn’t help.

Arrgh.  So frustrating.

 

Answered on March 22, 2017.
Add Comment

how about your laptop’s keyboard drivers. Can you try updating it? Or vice/versa “rollback drivers”.

 

Answered on March 22, 2017.
Add Comment

Laptop keyboard drivers are up to date and I don’t have the option to roll back drivers.

Ditto for mouse drivers.

 

Answered on March 22, 2017.
Add Comment

“Laptop keyboard drivers are up to date”.

Do not expect to see yellow triangle on keyboard logo in Device Manager. You can still double click on it and select “update driver”. I did it on my PC and updated a lot of devices.

If not help, go to your laptop’s manufacturer’s website and try downloading keyboard driver manually (you can even try driver for earlier windows version).

 

Answered on March 22, 2017.
Add Comment

Hi

lately I got a similar problem on a customers PC – disabling in AutoCAD the Desktop Analytics solved it:

https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-enable-or-disable-the-Desktop-Analytics-Program-in-AutoCAD.html

Cheers

Michael

Answered on March 24, 2017.
Add Comment

Thanks Michael

I’ve done as you suggested, still no difference.

I’ve realised that the problem is not limited to Autocad.. there is the same issue on Excel, Word, Chrome etc.. basically just a delay between keyboard input and the PC becoming responsive to mouse input.

I’ve pretty much given up on finding a solution.. next step is to throw PC out the window!

Answered on March 24, 2017.
Add Comment

Don’t open the window yet 🙂

Ok, I understand, not only AutoCAD is affected.

Is it a wireless keyboard?

Answered on March 24, 2017.
Add Comment

nope, it’s the laptop’s built-in one.
when i use the on-screen keyboard, the problem goes away. but obviously i can’t work like that.

Answered on March 24, 2017.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.