Delay after keyboard command

Please help.  I’ve been looking for a solution to this for 6 months already.

The problem started when I upgraded to Windows 10.  I was running Autocad 2016 at the time, have since upgraded to 2017 and also installed all service packs for Windows and Autocad, to no avail.

 

I bought a brand new Microsoft windows 10-compatible mouse, not the solution either.

Problem:

When I enter a command using the keyboard, there is a 1-2 second delay before I can select or click in the model space.  Eg. if I hit ‘L’ for line and I click in model space immediately, the click is ‘dead’.  If I wait a second or two before clicking, this does not happen.  BUT, if I use the toolbar button for line, I can click in model space and start drawing immediately.  A second doesn’t sound like much, but it is slowing me down considerably and frustrating me incredibly.

The same applies to any other keyboard command.   When I enter the command using the keyboard, I have to wait 1-2 seconds before I can select objects or start drawing.  The mouse is moving during these 1-2 seconds, it’s not like it freezes.  But the clicking has no effect.

I have searched everywhere for a solution and tweaked every setting I could find.

Does anyone have an ideas for how to fix this?

 

Asked on March 21, 2017 in AutoCAD.
Add Comment
25 Answer(s)
Best answer

It’s an MSI laptop.

I tried a few more things last night.  and after restarting the problem is finally fixed… after 6 months of struggling with it.  🙂

I think this is what did the trick:

 

Go to: Settings->Devices->Mouse and touchpad->Additional Mouse Options

Go to the TouchPad tab

Click on Additional tab

Palm tracking – slide all the way to minimum

 

 

Super simple fix but totally bizarre because I am not even using the touchpad, it is disabled and I am using a usb mouse.

 

Anyway my problem is solved.

 

 

Answered on March 29, 2017.

I am very glad that you were able to solve the problem, I have been busy searching myself for the past 4 days, it seemed like a most strange problem.   Hope all is well 🙂

on March 30, 2017.

Wooooooohooooooooo!!!! I’ve been following this thread with interest. Great to see it finally has been fixed.

6 months of agony resolved. Great to see so many people pitch in with ideas too!

on March 30, 2017.
Add Comment
  1. Have your tried with a different keyboard? It also worth trying virtual keyboard (to see if its definitely your keyboard)
  2. I assume you are working offline (not in a network environment)? Because if you work in a network environment and some AutoCAD setting direct to a network drive then this might be the cause.
Answered on March 21, 2017.
Add Comment

Hi there Wilson and welcome to CAD Answers community,

Try to turn off hardware acceleration for your Graphics Card and tell me how it goes, if it works; you might need to update your drivers.

from what you are describing it’s most probably drivers problem but which one? (Mouse, Display, Graphics)

We’ll tackle the problem one step at a time.

Regards

Mostafa

Answered on March 21, 2017.
Add Comment

Dynamic input can cause problems like this.

Answered on March 21, 2017.
Add Comment

Hi there KMWilson,

Let’s try to turn off windows key filtering

Adjust long delay in keystrokes appearing due to Windows FilterKeys

Here’s how: (Copied from Microsoft support)

Cause

This issue occurs if the Use FilterKeys check box is selected in the Accessibility Options item in Control Panel.

When you click to select the Use FilterKeys check box, your keyboard ignores brief or repeated keystrokes.

You can also adjust the keyboard repeat rate. The keyboard repeat rate is the rate at which a key repeats when you hold it down.

Resolution

To resolve this issue, click to clear the Use FilterKeys check box.

To do this on a Windows Vista-based or Windows 7-based computer, follow these steps:

  1. Click Start, click Control Panel, and then select Ease of Access Center.
  2. Select Change how your Keyboard works or Make the keyboard easier to use.
  3. Click to clear Turn on Filter Keys, or adjust the settings to a quicker rate.
  4. Close the Window.For more information about Using the Ease of Access Center, please visit the following Microsoft Web Site

    Choose your version of Windows, and review the Ease of Access Center training.

To do this on a Windows XP-based computer, follow these steps:

  1. Click Start, click Run, type access.cpl in the Open box, and then click OK.
  2. On the Keyboard tab in the Accessibility Options dialog box, click to clear the Use Filter keys check box, and then click OK.

 

 

 

Please do tell me how it goes.

Mostafa

Answered on March 22, 2017.
Add Comment

Hi BDobell

I’ve tried that already, Dynamic input is turned off.

Any other ideas?

 

Answered on March 21, 2017.
Add Comment

Hi SBCansever

I am working on a laptop, but have tried plugging in an external keyboard, it made no difference.

I am not working in a network environment.. it’s just me!

Any other ideas?

Answered on March 22, 2017.
Add Comment

Hi Mostafa

Thanks for helping.

I’ve turned off hardware acceleration via the graphicsconfig command, but it makes no difference.

Regards

Karin Wilson

 

Answered on March 21, 2017.
Add Comment

Good morning Karin,

I believe this is lag caused by the AUTOCOMPLETE function, which can be useful but is mostly annoying for experienced users.  You can edit the variables by typing AUTOCOMPLETE – change the delay or even turn it off.

Hope that fixes it,

Bill

Answered on March 22, 2017.
Add Comment

When you type full command, does it makes any difference? (i.e. type “LINE” instead of just “L”)

 

Answered on March 22, 2017.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.