AutoCAD 2017 has slowed down – How do I speed it up?

I’ve found that my AutoCAD has started to slow down even when designing on simple drawings.
I’m running AutoCAD 2017 on MacOS.
My iMac is only used for AutoCAD, it’s a high-spec iMac and I don’t have other apps running at the same time.

The application never crashes but it becomes noticeably slow. I’ve noticed this has happened with may designs I’m working on. Something isn’t right.

What should I do to troubleshoot this problem?

Add Comment
1 Answer(s)

Verify your hardware meets or surpasses the base system requirements. Keep in mind you will have different programs that may likewise take a lot of RAM on your system. On the off chance that you are anticipating running them in the meantime, you ought to have no less than 2GB of RAM free accessible when all programs are active. I comprehend this isn’t ideal for graphics execution, yet given that AutoCAD works easily at startup and I am not changing graphics settings trying to working on a drawing, I would not pinpoint my issue to the graphic card.¬†After some additional experimentation with working offline, disabling McAfee and various other programs, I found that disabling Citrix Receiver fixed the lagging AutoCAD performance. So far. For more info you can use this best essay writing service to having a wonderful assistant in writing and even you can have the writing guidelines too.

Answered on May 15, 2018.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.